1. BrokenBot 4.7.5 works with Clash of Clans May 2017 Update is out!
    [ Download Clash of Clans Bot BrokenBot for CoC ] [ NEW PREMIUM FEATURES RELEASED! ]

    BrokenBot 5.0 HAS BEEN ANNOUNCED! read the details here

    Buy BrokenBot Premium 1 Year - Get beta for free permanently! Excited to play with BrokenBot 5? So are we! Sign up now and save money when it comes out and also get access to beta!

    ALL PRICES WILL BE GOING UP AFTER BrokenBot 5.0 RELEASE. IF YOU DO NOT HAVE A MONTHLY SUBSCRIPTION, YOU HAVE BEEN WARNED!

    Click Here To Upgrade Right Now

[download] Brokenbot 4.7.5 - May 2017 Coc Update Working

Discussion in 'News and Announcements' started by Broken, May 24, 2017.

  1. Broken

    Broken Administrator Staff Member Premium User Beta Tester Founder Donator Enabler

    293
    64
    28
    BrokenBot 4.7.5

    Fixed to work with May 2017 update. No, we don't do anything with the broken boat yet, this is only restoring all functions that worked previously. While we have tested as much as possible this is still considered to be a public beta, you may find a few issues. Please just let us know what you find so we can fix them.

    This is an odd release as we were really hoping to have 5.0 released right now but the update made fixing that version extra complicated. This release then is an odd combination of some background improvements from 5.0 but overall the same bot as you had in 4.7.4. Come visit us often because we do hope to have 5.0 out very soon!

    Fixes/improvements from 4.7.4 beyond just working with May update:
    • Improved building detection and building detection speed -- huge boost for premium features such as weak base detection and weak wall detection
    • Increased training logic speed
    • Better handling of taking screenshots from the emulator -- makes for higher speed of bot use and reliability
    • Townhall detection fixes and fixes for boosting
    • Probably a lot of other background fixes I can't even think of -- we've done a ton of work reworking the behind the scenes logic for 5.0 that is also used in this.
    Warning - donations not working properly, please turn donating off for better performance until a fix is released.

    REMEMBER TO MANUALLY ZOOM OUT!
    -- this should be resolved in 5.0 but we were unable to move this code back into 4.7.5

    Important note: as part of the 5.0 changes, we have updated several of our dependencies. Make sure you run the file setup.exe to ensure all needed features get installed!

    FREE PREMIUM
    As a gift to you all, we are going to activate premium features for ALL users from midnight tonight (US eastern time zone) until we release 5.0 beta. Give it a shot and see how many extra resources you can get just by attacking weak bases.


    BrokenBot Remote on the App Store

    BrokenBot Remote - Android Apps on Google Play
     

    Attached Files:

    Last edited: May 24, 2017
  2. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    <mic drop> That will shut down all the nay-sayers. Downloading now and will fire it up on multiple clients and report any issues...
     
    maxcom likes this.
  3. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    ...and you weren't kidding. Detection is WAY faster in this 4.7.5 than in 4.7.4. Only downside is settings still get reverted to defaults, so had to re-do those, but that's only a few seconds. Thanks!!!!!!
     
    Broken and maxcom like this.
  4. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    Ok, three bots up and running. Confirming that all of the below is working (all 3 are currently running various flavors of AxEgo's B.Arch Dead Base Collector Attack v1.01):
    • Base detection (one client couldn't detect TH level only, rest picked up everything automatically). Actually, same client couldn't detect TH9 base level after restarting, either, so I'm chalking that up to image detection. Probably minor.
    • Attack Searches, including weak base detection (Premium feature)
    • Reloading of base defenses, including inferno towers (TH9 and TH10 both at least)
    • Collection from collectors/DE drills
    Things that aren't working in 4.7.5:
    • Donations. <sadface> Sadly, it looks like it's trying and then doesn't actually donate anything -- all three of mine fail to donate. This looks more like a detection issue than a functional problem. Will continue to watch and monitor this.
    • Super-trivial, but it looks like the default window width of the client changed from 4.7.4 to 4.7.5. When shrunk to its smallest width, the right side scroll bar is halfway chopped off (same w/ the logging level drop-down arrow and the snapshot button at top). You have to manually drag the right edge of the app over a little to compensate.
    Things I've put in the not-sure column, at least for now:
    • Attacks. On three separate attacks across all 3 bots (AxEgo B.Arch attack strategy), I watched each of them mass-dump all the Barbarians at once right up front, leaving none for individual collectors later on. I just confirmed this again -- it dumped ALL the Barbs at once. That negates this strategies usefulness entirely. It may only affect Barbarians, or it may only be this strategy. Need to test some others. Here's a screeenshot showing the verbose logs and the mass deployment of the second batch of supposed-to-be-eight Barbs: Imgur: The most awesome images on the Internet . And here are the logs from that attack: Broken Barbarian Deployment - Pastebin.com. And just because, here's another shot from another attack (different account) showing the same mass-dump of Barbs: Imgur: The most awesome images on the Internet.
    Still testing and will report more as found....
     
    Last edited: May 24, 2017
  5. Broken

    Broken Administrator Staff Member Premium User Beta Tester Founder Donator Enabler

    293
    64
    28
    Thanks for the feedback.

    Base detection - I can't seem to replicate when or why this happens. I think it may relate to whether the bot started the emulator or if the game was already running and ready to go.
    Window width - We have actually changed UI components so that all of our UI runs much quicker now. This has messed up the visual presentation as you noted.

    Both of the above I consider to be minor issues and neither exist in 5.0 so I wasn't going to invest serious time in fixing them. I'd prefer you just have a working bot.

    Donations - :( sorry, I'll look at getting a hotfix in preparation as I know this is important
    Attacks - Very weird that you are having all troops dump like that. I have personally been using VIPINVITE BAM Dead Bases and another very basic Barch attack of collectors without a problem. I'll review your logfile to see if something sticks out.

    To be 100% honest, Maxcom and I have already shifted our focus back onto getting all the fixes necessary into 5.0 (it was so incredibly close to done!) but if we see some glaring issues that we can quickly resolve in this we will consider it
     
  6. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    Let me watch donations a little more before you even look there too hard.
    Base detection at this point is good enough 99% of the time.

    I'm testing attack strategy YouWillNot TH10 Live/Dead DE Focus+Trophy now (mix of troops from barb to wiz) to see what happens there. Stay tuned.
     
  7. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    YouWillNot TH10 Live/Dead DE Focus properly deployed all the barbarians... 5 or 6 at a time. So I'm going to nuke and re-download the AxEgo B.Arch strategy and make sure it's not something there. I did not change the strategy at all from his, except perhaps a few minor search criteria adjustments.

    So the good news is, it doesn't seem to be a "Barbarian deploy is broken" thing. It may just be me... but across 3 clients it's definitely something I need to track down.

    (Also, 4.7.5 client still shows "4.7.4" in the "Welcome to..." at the top.)
     
  8. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    Ok, there's definitely something "odd" with the AxEgo strategy. Even after deleting and re-grabbing, it definitely deploys all the Barbs on the second round of deployment. Archers work fine. Playing around with a few more strategies...
     
  9. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    Even weirder....

    AxEgo TH9 B.Arch v1.01 dumps all the Barbs on the second iteration of deployment on my TH9 client.
    AxEgo TH10/TH11 B.Arch v1.01 works fine on both my TH10-level clients.

    YouWillNot Th10 Live Dead DE Focus+Trophy seems to deploy everything properly -- Giants, Wizards, Barbs, Archers, Wallbreakers, BK and heal/rage spells on my TH10 client.

    So this looks more like a TH9 issue... and maybe it's because I have both heroes upgrading or something like that. Who knows... probably not worth chasing too hard unless other people have similar issues with TH9 or all-Barb dumping, but I will have to find another working farm strategy for the TH9 client.

    One other note: I've seen BB restart itself numerous times during the donation pass:


    2017-05-24T15:33:27.2464604-04:00: Thread:7:26899720 [INFO] Clan: Donating troops...
    2017-05-24T15:33:30.5635676-04:00: Thread:7:29660784 [DEBUG] Chat: Donate Spells location: (251, 126)
    2017-05-24T15:33:30.5818217-04:00: Thread:7:32195212 [VERBOSE] Chat: Donation text: any . thanks1
    2017-05-24T15:33:30.5821509-04:00: Thread:7:32203404 [VERBOSE] Chat: Blacklisted! Request contains: 1
    2017-05-24T15:33:30.8620079-04:00: Thread:7:36785144 [DEBUG] Chat: Donate Spells location: (251, 229)
    2017-05-24T15:33:30.8931112-04:00: Thread:7:45111360 [VERBOSE] Chat: Donation text: anything . thank s
    2017-05-24T15:33:30.8931112-04:00: Thread:7:45113956 [DEBUG] Clan: Trying to donate Barbarians but there is no room for troops.
    2017-05-24T15:33:30.8931112-04:00: Thread:7:45117776 [DEBUG] Clan: Trying to donate Archers but there aren't any ready.
    2017-05-24T15:33:33.2684000-04:00: Thread:7:27903984 [DEBUG] Chat: Donate Troops location: (248, 331)
    2017-05-24T15:33:33.2868183-04:00: Thread:7:30440196 [VERBOSE] Chat: Donation text: any . thanks1
    2017-05-24T15:33:33.2868183-04:00: Thread:7:30441032 [VERBOSE] Chat: Blacklisted! Request contains: 1
    2017-05-24T15:33:33.5772486-04:00: Thread:7:35865404 [DEBUG] Chat: Donate Troops location: (248, 434)
    2017-05-24T15:33:33.5944321-04:00: Thread:7:38416212 [VERBOSE] Chat: Donation text: anything
    2017-05-24T15:33:34.4820570-04:00: Thread:7:18394460 [DEBUG] Clan: Trying to donate Barbarians but request has been filled.
    2017-05-24T15:33:36.8838364-04:00: Thread:7:23774568 [DEBUG] Chat: No valid donation buttons found.
    2017-05-24T15:33:37.4819291-04:00: Thread:7:26398984 [DEBUG] BrokenBot: Failed to find builder eye.
    2017-05-24T15:33:37.6410926-04:00: Thread:7:20526840 [VERBOSE] BrokenBot: Searching for main screen...
    2017-05-24T15:33:44.0044951-04:00: Thread:7:25709696 [DEBUG] BrokenBot: Obstacle checking function called, but no obstacles were ever found.
    2017-05-24T15:33:44.0044951-04:00: Thread:7:25715492 [INFO] BlueStacks: Restarting Clash of Clans
    2017-05-24T15:34:02.3622592-04:00: Thread:7:25806072 [DEBUG] BlueStacks: Found CoC load progress bar in 8303 ms.
    2017-05-24T15:34:02.3622592-04:00: Thread:7:25809168 [DEBUG] BlueStacks: Waiting for CoC load progress bar to fill...
    2017-05-24T15:34:11.8103548-04:00: Thread:7:28433756 [DEBUG] BlueStacks: Made it to main screen in 9447 ms.
    2017-05-24T15:34:11.8105742-04:00: Thread:7:28444940 [DEBUG] BlueStacks: Total load time: 17751 ms.
    2017-05-24T15:34:11.8105742-04:00: Thread:7:28447936 [INFO] BlueStacks: Clash of Clans loaded.
    2017-05-24T15:34:16.6608929-04:00: Thread:7:30082688 [VERBOSE] BrokenBot: Searching for main screen...
     
  10. Broken

    Broken Administrator Staff Member Premium User Beta Tester Founder Donator Enabler

    293
    64
    28
    Probably part of the donation code failure. It opens up the chat screen then can't figure out how to close it so eventually falls back to the "oh shit I'm lost" function where it restarts the game. I'd recommend turning off donations until I get this fixed.
     
  11. rten77

    rten77 New Member

    5
    0
    1
    I am getting error reading number of troops in overview over and over, not sure how to fix it.
     
  12. Broken

    Broken Administrator Staff Member Premium User Beta Tester Founder Donator Enabler

    293
    64
    28
    Please PM me your log file
     
  13. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    CORRECTING observations from above... even the AxEgo TH10/TH11 mass-dumps Barbarians on one of my TH10 clients, but it does so on the third pass (third set of Barbs being dropped). And then on the next attack it performs exactly like it's supposed to. Running both of these stock/no changes, and they worked perfectly w/ 4.7.4, so I'm at a loss. Guess I'm looking for another fill 'er up strategy for TH9/TH10 in the meantime.
     
    Last edited: May 24, 2017
  14. hlygrail

    hlygrail Active Member Premium User Beta Tester

    243
    32
    28
    Just so there's no doubt... screenshots three of my clients from the last 4-5 hours of running BB 4.7.5:

    TH10 #1:
    clash of clans bot cocbot

    TH10 #2:
    clash of clans bot cocbot

    TH9:
    clash of clans bot cocbot

    Consistently 500k/500k+ per hour, and one of them is almost 700k/600k. Premium weak base detection really does make an appreciable difference, and because 4.7.5 is running faster than 4.7.4, it's making a few more hits per hour as well.

    I reeeeallly need those 10 builders now...
     
  15. MrJackSparrow2

    MrJackSparrow2 Member Premium User Beta Tester

    135
    13
    18
    Does the weak base wall detection work with TH11 walls now? They weren't detected properly in the last version.

    Thanks so much for the quick work you guys! It's much appreciated!
     
  16. SnotBubbles

    SnotBubbles New Member

    10
    0
    1
    Hmmm , mine is not searching now... Log uploaded
     
  17. maxcom

    maxcom Administrator Staff Member Premium User Beta Tester Founder Donator Enabler

    2,434
    85
    48
    Wanted to let everyone know that if you restart BrokenBot - you should all now have premium access until BB5 release shortly.

    Please let me know if you have any issues.

    P.S. last reminder - premium prices for anyone without an active subscription when BB5 is released will be going up.
     
    Last edited: May 25, 2017
    gokucorp likes this.
  18. MrJackSparrow2

    MrJackSparrow2 Member Premium User Beta Tester

    135
    13
    18
    I'm getting "fatal error in one or more threads" when the bot tries to train. It populates some of the quick train (per the log) but crashes and restarts over and over where it used to train and search. I tried with and without having quick train slots. This is happening on multiple accounts and multiple machines.
     
  19. gokucorp

    gokucorp New Member Beta Tester

    20
    4
    3
  20. R3DF13LD

    R3DF13LD Member Premium User Beta Tester

    102
    7
    18
    Going to test this with new memu 3.0.7.1 thanks bb team
     

Share This Page